PCS開発チーム

PCS開発チーム

Laravel10から11への更新時にスリム化に追従する場合

互換維持のためにこのパッケージのインストールが必要。
https://github.com/laravel/previously-on-laravel-10

composer require laravel/previously-on-laravel-10

中身はこれだけ。

    public function register(): void
    {
        VendorPublishCommand::dontUpdateMigrationDates();
    }

ただしスリム化への追従は推奨されてないのでどうしても追従したい場合のみ。
このパッケージを今後もずっとインストールし続ける手間を考えると無理しない方がいいかも。

追記

ドキュメントからpreviously-on-laravel-10の記載が消えたので不要かも。